summaryrefslogtreecommitdiff
path: root/test/polkit/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/polkit/Makefile.am')
-rw-r--r--test/polkit/Makefile.am46
1 files changed, 46 insertions, 0 deletions
diff --git a/test/polkit/Makefile.am b/test/polkit/Makefile.am
new file mode 100644
index 0000000..70fbf67
--- /dev/null
+++ b/test/polkit/Makefile.am
@@ -0,0 +1,46 @@
+
+NULL =
+
+INCLUDES = \
+ -I$(top_builddir)/src \
+ -I$(top_srcdir)/src \
+ -DPACKAGE_LIBEXEC_DIR=\""$(libexecdir)"\" \
+ -DPACKAGE_SYSCONF_DIR=\""$(sysconfdir)"\" \
+ -DPACKAGE_DATA_DIR=\""$(datadir)"\" \
+ -DPACKAGE_BIN_DIR=\""$(bindir)"\" \
+ -DPACKAGE_LOCALSTATE_DIR=\""$(localstatedir)"\" \
+ -DPACKAGE_LOCALE_DIR=\""$(localedir)"\" \
+ -DPACKAGE_LIB_DIR=\""$(libdir)"\" \
+ -D_POSIX_PTHREAD_SEMANTICS \
+ -D_REENTRANT \
+ $(NULL)
+
+AM_CFLAGS = \
+ $(GLIB_CFLAGS) \
+ $(NULL)
+
+LDADD = \
+ $(GLIB_LIBS) \
+ $(top_builddir)/src/polkit/libpolkit-gobject-1.la \
+ $(NULL)
+
+TEST_PROGS =
+
+# ----------------------------------------------------------------------------------------------------
+
+TEST_PROGS += polkitunixusertest
+polkitunixusertest_SOURCES = polkitunixusertest.c
+
+TEST_PROGS += polkitunixgrouptest
+polkitunixgrouptest_SOURCES = polkitunixgrouptest.c
+
+TEST_PROGS += polkitidentitytest
+polkitidentitytest_SOURCES = polkitidentitytest.c
+
+# ----------------------------------------------------------------------------------------------------
+
+check_PROGRAMS = $(TEST_PROGS)
+TESTS = $(TEST_PROGS)
+
+clean-local :
+ rm -f *~