summaryrefslogtreecommitdiff
path: root/src/polkitbackend/Makefile.am
diff options
context:
space:
mode:
authorDavid Zeuthen <davidz@redhat.com>2010-07-28 15:29:14 -0400
committerDavid Zeuthen <davidz@redhat.com>2010-07-28 15:29:14 -0400
commit6486dea34072ac4b666d00fcfe8f620df3ccd7f8 (patch)
treeb74461e155f924dcf7ad84d9ededd705bcf7e990 /src/polkitbackend/Makefile.am
parent3fee22546b76d377c6238943f2f0bcfb00c8f79c (diff)
Port CK class to gdbus
Also simplify the code it by using the on-disk database. Makes everything a lot simpler. Signed-off-by: David Zeuthen <davidz@redhat.com>
Diffstat (limited to 'src/polkitbackend/Makefile.am')
-rw-r--r--src/polkitbackend/Makefile.am21
1 files changed, 2 insertions, 19 deletions
diff --git a/src/polkitbackend/Makefile.am b/src/polkitbackend/Makefile.am
index 4cb7310..968c1b8 100644
--- a/src/polkitbackend/Makefile.am
+++ b/src/polkitbackend/Makefile.am
@@ -17,22 +17,6 @@ INCLUDES = \
-DEGG_DBUS_I_KNOW_API_IS_SUBJECT_TO_CHANGE \
$(NULL)
-BUILT_SOURCES = \
- ck-built-sources.stamp \
- $(NULL)
-
-ck-built-sources.stamp : Makefile.am $(srcdir)/org.freedesktop.ConsoleKit.xml
- eggdbus-binding-tool \
- --namespace "Ck" \
- --dbus-namespace "org.freedesktop.ConsoleKit" \
- --introspection-xml $(top_srcdir)/src/polkitbackend/org.freedesktop.ConsoleKit.xml \
- --stamp-file ck-built-sources.stamp \
- $(NULL)
-
-# keep in sync with contents of ck-built-sources.stamp (Thanks autotools)
-#
-ck_built_sources = ckbindingsmarshal.c ckbindingsmarshal.h ckbindingsmarshal.list ckbindings.c ckbindings.h ckbindingstypes.h cksession.c cksession.h docbook-interface-org.freedesktop.ConsoleKit.Session.xml ckseat.c ckseat.h docbook-interface-org.freedesktop.ConsoleKit.Seat.xml ckmanager.c ckmanager.h docbook-interface-org.freedesktop.ConsoleKit.Manager.xml ckerror.c ckerror.h docbook-enum-Error.xml ckdevice.c ckdevice.h docbook-struct-Device.xml
-
lib_LTLIBRARIES=libpolkit-backend-1.la
libpolkit_backend_1includedir=$(includedir)/polkit-1/polkitbackend
@@ -51,7 +35,6 @@ libpolkit_backend_1include_HEADERS = \
$(NULL)
libpolkit_backend_1_la_SOURCES = \
- $(ck_built_sources) \
$(BUILT_SOURCES) \
polkitbackend.h \
polkitbackendtypes.h \
@@ -94,10 +77,10 @@ EXTRA_DIST = \
$(NULL)
dist-hook :
- (for i in $(ck_built_sources) $(BUILT_SOURCES) ; do rm -f $(distdir)/$$i ; done)
+ (for i in $(BUILT_SOURCES) ; do rm -f $(distdir)/$$i ; done)
clean-local :
- rm -f *~ $(ck_built_sources) $(BUILT_SOURCES)
+ rm -f *~ $(BUILT_SOURCES)
install-exec-hook:
mkdir -p $(DESTDIR)$(localstatedir)/lib/polkit-1