summaryrefslogtreecommitdiff
path: root/src/polkitbackend/Makefile.am
diff options
context:
space:
mode:
authorColin Walters <walters@verbum.org>2016-12-12 12:39:43 -0500
committerColin Walters <walters@verbum.org>2016-12-12 12:39:43 -0500
commit3272a988655c3236b55bad70e9a3af20857f384b (patch)
tree9a033fd20ac274a68e53a618b93a942019d75cfa /src/polkitbackend/Makefile.am
parent2d4d117eeadde9b56ac49e82a2d701a6f6e387b5 (diff)
build: Pull in GCC warning infra from ostree
I'm trying to keep a relatively standard set around, and the code there is cleaner than what we had before. Also, injecting as WARN_CFLAGS rather than changing CFLAGS during autoconf avoids any surprises from new warnings breaking autoconf checks.
Diffstat (limited to 'src/polkitbackend/Makefile.am')
-rw-r--r--src/polkitbackend/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/polkitbackend/Makefile.am b/src/polkitbackend/Makefile.am
index ca62474..e48b739 100644
--- a/src/polkitbackend/Makefile.am
+++ b/src/polkitbackend/Makefile.am
@@ -2,6 +2,7 @@ NULL =
BUILT_SOURCES =
+AM_CFLAGS = -std=gnu99 $(WARN_CFLAGS)
AM_CPPFLAGS = \
-I$(top_builddir)/src \
-I$(top_srcdir)/src \