summaryrefslogtreecommitdiff
path: root/src/polkitbackend/Makefile.am
diff options
context:
space:
mode:
authorDavid Zeuthen <davidz@redhat.com>2009-02-08 16:23:45 -0500
committerDavid Zeuthen <davidz@redhat.com>2009-02-08 16:23:45 -0500
commit21e21e97cd2b663ae96efe62c8f6cc69edbd1d3c (patch)
tree6efcdce824c817bdc381da8bc8250a8b2668cba1 /src/polkitbackend/Makefile.am
parentbc150368d95ef70b04af3bc9250c1bdfe950a048 (diff)
load and choose what backend to use; also write a simple null backend
The thinking is that if someone wants to turn off PolicyKit, they simply drop a file /etc/polkit-1/nullbackend.conf.d/99-i-hate-polkit.conf with the contents [Configuration] priority=1000 This also provides a good cut-n-paste template / example etc. of how to implement a PolicyKit backend.
Diffstat (limited to 'src/polkitbackend/Makefile.am')
-rw-r--r--src/polkitbackend/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/polkitbackend/Makefile.am b/src/polkitbackend/Makefile.am
index 5f10f9e..a505fa7 100644
--- a/src/polkitbackend/Makefile.am
+++ b/src/polkitbackend/Makefile.am
@@ -84,3 +84,4 @@ clean-local :
install-exec-hook:
mkdir -p $(DESTDIR)$(localstatedir)/lib/polkit-1
-chmod 600 $(DESTDIR)$(localstatedir)/lib/polkit-1
+ mkdir -p $(DESTDIR)$(libdir)/polkit-1/backends