summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRay Strode <rstrode@redhat.com>2011-03-28 22:14:34 -0400
committerRay Strode <rstrode@redhat.com>2011-03-28 22:45:48 -0400
commit537c16422cd49f1beeaab1ad39846a00018faec1 (patch)
treeabf0ca57358970bd5c8c9d24414c50032a63e97f /configure.ac
parent7f3871b0f5c7c90057c66bd38ad63043a61f40e6 (diff)
systemd: toggle systemd messages when toggling console redirection
Normally systemd is very mute about messages. It's important, though for it to be chatty when plymouth is running so we can show verbose messages to the user when they hit escape. This commit adds a new --enable-systemd-integration configure flag which explicitly tells systemd when to print messages to the console. This may get dropped in the future in lieu of init script changes doing this instead of plymouth directly.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 7 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index da9e03db..205607eb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -242,6 +242,13 @@ if test x$enable_upstart_monitoring = xyes; then
fi
AM_CONDITIONAL(ENABLE_UPSTART_MONITORING, [test "$enable_upstart_monitoring" = yes])
+AC_ARG_ENABLE(systemd-integration, AS_HELP_STRING([--enable-systemd-integration],[coordinate boot up with systemd]),enable_systemd_integration=$enableval,enable_systemd_integration=no)
+AM_CONDITIONAL(ENABLE_SYSTEMD_INTEGRATION, [test "$enable_systemd_integration" = yes])
+
+if text x$enable_systemd_integration = xyes; then
+ AC_DEFINE(PLY_ENABLE_SYSTEMD_INTEGRATION, 1, [Coordinate boot up with systemd])
+fi
+
AC_ARG_WITH(system-root-install, AS_HELP_STRING([--with-system-root-install],[Install client in /bin and daemon in /sbin]),with_system_root_install=${withval},with_system_root_install=yes)
AM_CONDITIONAL(WITH_SYSTEM_ROOT_INSTALL, [test "$with_system_root_install" = yes])