summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2015-03-20 13:02:35 -0400
committerRay Strode <rstrode@redhat.com>2015-03-20 13:04:12 -0400
commit4519fe0db5eb00e8a29b3eeb144e4ada4fe971dc (patch)
tree1c4a13b41f622981cbd63a3d7be7c3699d6c55eb /configure.ac
parent9d62fefeed977b5123b531ce6a35a50f5107767f (diff)
systemd: Allow specifying unit dir to configure
systemd isn't necessarily in the buildroot at the time that plymouth gets built, so autodetection of the unitdir from pkgconfig isn't necessarily feasible. This commit adds a new option to configure, --with-systemdunitdir, that lets distros specify the unit directory manually. https://bugs.gentoo.org/show_bug.cgi?id=543712
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 110cc691..445034d3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -122,7 +122,12 @@ AM_CONDITIONAL(ENABLE_SYSTEMD_INTEGRATION, [test "$enable_systemd_integration" =
if test x$enable_systemd_integration = xyes; then
AC_DEFINE(PLY_ENABLE_SYSTEMD_INTEGRATION, 1, [Coordinate boot up with systemd])
- SYSTEMD_UNIT_DIR=$($PKG_CONFIG --variable=systemdsystemunitdir systemd)
+ AC_ARG_WITH([systemdunitdir], AC_HELP_STRING([--with-systemdunitdir=DIR],
+ [path to systemd service directory]), [path_systemdunit=${withval}],
+ [path_systemdunit="`$PKG_CONFIG --variable=systemdsystemunitdir systemd`"])
+ if (test -n "${path_systemdunit}"); then
+ SYSTEMD_UNIT_DIR="${path_systemdunit}"
+ fi
AC_SUBST(SYSTEMD_UNIT_DIR)
fi