summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRay Strode <rstrode@redhat.com>2010-10-13 08:26:42 -0400
committerRay Strode <rstrode@redhat.com>2010-10-13 08:26:42 -0400
commit0f1b124a2b5bf620197318b0fbe9a506d4c7e6e9 (patch)
treecbfa0350f9d6f346ae86dabf34fe3e7860dba385 /configure.ac
parentd7f59d9dc29c73fd72a7c0823ad5738211863b39 (diff)
populate-initrd: pre-expand logofile variable
The logofile by default is $datadir/plymouth.png $datadir contains a reference to $datarootdir, so we need to preexpand the variable in configure, for the right value to get written to plymouth-populate-initrd.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 664a6c7d..b5927340 100644
--- a/configure.ac
+++ b/configure.ac
@@ -155,6 +155,7 @@ AM_CONDITIONAL(START_FROM_GDM, [test "$with_gdm_autostart_file" = yes])
AC_ARG_WITH(logo, AS_HELP_STRING([--with-logo],[logo used by boot splash plugins]),logofile=${withval},logofile=$datadir/plymouth/bizcom.png)
AC_SUBST(logofile)
+AS_AC_EXPAND(PLYMOUTH_LOGO_FILE, $logofile)
AM_CONDITIONAL(INSTALL_FALLBACK_LOGO, [test "$logofile" = $datadir/plymouth/bizcom.png])