summaryrefslogtreecommitdiff
path: root/src/mesa/drivers/osmesa/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/mesa/drivers/osmesa/Makefile.am')
-rw-r--r--src/mesa/drivers/osmesa/Makefile.am50
1 files changed, 50 insertions, 0 deletions
diff --git a/src/mesa/drivers/osmesa/Makefile.am b/src/mesa/drivers/osmesa/Makefile.am
new file mode 100644
index 00000000000..3cf3005071a
--- /dev/null
+++ b/src/mesa/drivers/osmesa/Makefile.am
@@ -0,0 +1,50 @@
1
2
3# Copyright © 2012 Laurent Carlier <lordheavym@gmail.com>
4#
5# Permission is hereby granted, free of charge, to any person obtaining a
6# copy of this software and associated documentation files (the "Software"),
7# to deal in the Software without restriction, including without limitation
8# the rights to use, copy, modify, merge, publish, distribute, sublicense,
9# and/or sell copies of the Software, and to permit persons to whom the
10# Software is furnished to do so, subject to the following conditions:
11#
12# The above copyright notice and this permission notice (including the next
13# paragraph) shall be included in all copies or substantial portions of the
14# Software.
15#
16# THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
17# IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
18# FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL
19# THE AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
20# LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING
21# FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS
22# IN THE SOFTWARE.
23
24# Hack to make some of the non-automake variables work.
25TOP=$(top_builddir)
26
27AM_CFLAGS = \
28 -I$(top_srcdir)/include \
29 -I$(top_srcdir)/src/mapi \
30 -I$(top_srcdir)/src/mesa/ \
31 $(DEFINES) \
32 $(API_DEFINES)
33
34if HAVE_OSMESA_DRIVER
35lib_LTLIBRARIES = lib@OSMESA_LIB@.la
36endif
37
38lib@OSMESA_LIB@_la_SOURCES = osmesa.c
39
40lib@OSMESA_LIB@_la_LDFLAGS = -module -version-number @OSMESA_VERSION@ -shared
41lib@OSMESA_LIB@_la_LIBADD = \
42 $(top_builddir)/src/mesa/libmesa.a \
43 $(top_builddir)/src/mapi/glapi/libglapi.a \
44 $(top_builddir)/src/glsl/libglsl.a
45
46# Provide compatibility with scripts for the old Mesa build system for
47# a while by putting a link to the driver into /lib of the build tree.
48all-local: lib@OSMESA_LIB@.la
49 $(MKDIR_P) $(top_builddir)/$(LIB_DIR);
50 ln -f .libs/lib@OSMESA_LIB@.so $(top_builddir)/$(LIB_DIR)/lib@OSMESA_LIB@.so;