summaryrefslogtreecommitdiff
path: root/src/demos/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/demos/CMakeLists.txt')
-rw-r--r--src/demos/CMakeLists.txt8
1 files changed, 6 insertions, 2 deletions
diff --git a/src/demos/CMakeLists.txt b/src/demos/CMakeLists.txt
index f1614fda..55e7bb3b 100644
--- a/src/demos/CMakeLists.txt
+++ b/src/demos/CMakeLists.txt
@@ -17,6 +17,8 @@ link_libraries (
${GLEW_glew_LIBRARY}
)
+set (subdir demos)
+
set (targets
arbfplight
arbfslight
@@ -74,12 +76,14 @@ set (targets
)
foreach (target ${targets})
- add_executable (${target} ${target}.c)
+ add_executable (${subdir}_${target} ${target}.c)
+ set_target_properties (${subdir}_${target} PROPERTIES OUTPUT_NAME ${target})
+ install (TARGETS ${subdir}_${target} DESTINATION ${subdir})
endforeach (target)
add_executable (rain rain.cxx particles.cxx)
-install (TARGETS ${targets} rain DESTINATION demos)
+install (TARGETS rain DESTINATION demos)
file (GLOB data *.dat)