summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatúš Kukan <matus.kukan@collabora.com>2014-03-31 19:18:41 +0200
committerMatúš Kukan <matus.kukan@collabora.com>2014-04-01 11:04:33 +0200
commitde7cdbc5840fd7d958d486901e405890eff224b9 (patch)
tree17de32fdc1bc69138c44ca22c81d3115871c8f2a /configure.ac
parent8dc394d5c573e5583760c7cc56c5c19062d3f062 (diff)
Install coinmp and lpsolve linear solvers in parallel.
Change-Id: If07d94a2f646c8377b76fdf645e85f9491e4f061
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 13 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index f039f1b835e8..3bd45759b6c9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -654,6 +654,7 @@ linux-android*)
enable_lotuswordpro=no
enable_mpl_subset=yes
enable_opengl=no
+ enable_coinmp=no
enable_lpsolve=no
enable_report_builder=no
with_theme="tango"
@@ -7323,6 +7324,7 @@ if test $_os = iOS; then
enable_mpl_subset=yes
enable_opengl=no
enable_lotuswordpro=no
+ enable_coinmp=no
enable_lpsolve=no
enable_postgresql_sdbc=no
enable_lotuswordpro=no
@@ -9408,8 +9410,17 @@ dnl ===================================================================
dnl How should we build the linear programming solver ?
dnl ===================================================================
-# Should we check for system CoinMP ? How to do that ?
-BUILD_TYPE="$BUILD_TYPE COINMP"
+ENABLE_COINMP=
+AC_MSG_CHECKING([whether to build with CoinMP])
+if test "$enable_coinmp" != "no"; then
+ ENABLE_COINMP=TRUE
+ AC_MSG_RESULT([yes])
+ # Should we check for system CoinMP ? How to do that ?
+ BUILD_TYPE="$BUILD_TYPE COINMP"
+else
+ AC_MSG_RESULT([no])
+fi
+AC_SUBST(ENABLE_COINMP)
ENABLE_LPSOLVE=
AC_MSG_CHECKING([whether to build with lpsolve])