summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2014-09-29 17:30:13 +0200
committerMichael Stahl <mstahl@redhat.com>2014-10-01 21:17:27 +0000
commitd08110c0be9e5290240082d899d45938730684eb (patch)
tree55c768dae225eff428e66cf67f9841c4c34704e8 /configure.ac
parent870befe9847eda85a8a5e48697486a4cf7b4ed7f (diff)
configure: limit JunitTest VM usage
By default JVM will allocate a significant chunk of the available system VM, but our JunitTest run well for me with just 64 MB of max heap, so set this as a limit at least for Sun JVMs, to have tests running more smoothly on OS that lack VM over-commit. Change-Id: I5e4b5595decc3a133e7e285dfd7463d436fa458d Reviewed-on: https://gerrit.libreoffice.org/11698 Reviewed-by: David Ostrovsky <david@ostrovsky.org> Tested-by: David Ostrovsky <david@ostrovsky.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac3
1 files changed, 3 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 4e2eec999fe4..af2bda898352 100644
--- a/configure.ac
+++ b/configure.ac
@@ -6712,6 +6712,9 @@ you must use the "--with-jdk-home" configure option explicitly])
if test "$_os" = "WINNT"; then
JAVA_HOME=`echo $JAVA_HOME | $SED "s,\.[[eE]][[xX]][[eE]]$,,"`
fi
+
+ # set to limit VM usage for JunitTests
+ JAVAIFLAGS=-Xmx64M
fi
else
AC_MSG_ERROR([Java not found. You need at least jdk-1.5, or gcj-4])