summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorLuboš Luňák <l.lunak@collabora.com>2014-09-13 23:47:46 +0200
committerLuboš Luňák <l.lunak@collabora.com>2014-09-14 22:07:05 +0200
commitbe048935c5e9e5d98a349d2fa25e7c2dfbe757dc (patch)
tree1388c48f548ffc82e9c0985d7adacc13abe1a918 /configure.ac
parentaa3696b1ac6c66865d24300e92eed57fff8efbef (diff)
boost signals2 with clang and C++11 require at least boost 1.55
https://svn.boost.org/trac/boost/ticket/8260 Change-Id: I06b4d45b91c99d1152fa79e419346c0668573bca
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 6 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 1f5a79469087..c2d602e2edb8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8527,13 +8527,18 @@ if test "$with_system_boost" = "yes"; then
fi
AC_LANG_PUSH([C++])
save_CXXFLAGS=$CXXFLAGS
- CXXFLAGS="$CXXFLAGS $BOOST_CPPFLAGS"
+ CXXFLAGS="$CXXFLAGS $BOOST_CPPFLAGS $CXXFLAGS_CXX11"
AC_CHECK_HEADER(boost/shared_ptr.hpp, [],
[AC_MSG_ERROR(boost/shared_ptr.hpp not found. install boost)], [])
AC_CHECK_HEADER(boost/spirit/include/classic_core.hpp, [],
[AC_MSG_ERROR(boost/spirit/include/classic_core.hpp not found. install boost >= 1.36)], [])
AC_CHECK_HEADER(boost/function.hpp, [],
[AC_MSG_ERROR(boost/function.hpp not found. install boost)], [])
+ AC_MSG_CHECKING([whether boost signals2 works])
+ AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <boost/signals2/signal.hpp>]],
+ [[ boost::signals2::signal<void()> s; s(); ]])],
+ [AC_MSG_RESULT([yes])],
+ [AC_MSG_ERROR([no, install boost >= 1.55 or use --without-system-boost])])
CXXFLAGS="$CXXFLAGS -fno-exceptions"
AC_MSG_CHECKING([whether boost/function.hpp compiles with -fno-exceptions])
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <boost/function.hpp>