summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarkus Mohrhard <markus.mohrhard@googlemail.com>2015-11-15 04:39:24 +0100
committerMarkus Mohrhard <markus.mohrhard@googlemail.com>2016-02-22 18:20:13 +0000
commita46ef637d5f37962f826969cb2d7eb4cb9ba81c6 (patch)
treee60a0d3c0e716ace76db0fc71bb343adff0b6f6b /configure.ac
parente72cd4053676d826ef9a914e62e89e26247bdd5c (diff)
include breakpad into the build
Change-Id: I1bfd107502332fc86ae5e96bbc1f475b8d669c6c Reviewed-on: https://gerrit.libreoffice.org/22547 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Markus Mohrhard <markus.mohrhard@googlemail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 20 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index aabe5583c738..78253497f883 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1038,6 +1038,11 @@ AC_ARG_ENABLE(graphite,
[Disables the compilation of Graphite smart font rendering.])
)
+AC_ARG_ENABLE(breakpad,
+ AS_HELP_STRING([--enable-breakpad],
+ [Enables breakpad for crash reporting.])
+)
+
AC_ARG_ENABLE(orcus,
AS_HELP_STRING([--enable-orcus],
[Enables orcus for extra file import filters for Calc.])
@@ -9079,6 +9084,21 @@ else
fi
AC_SUBST(ENABLE_GRAPHITE)
+dnl ==================================================================
+dnl Breakpad
+dnl ==================================================================
+AC_MSG_CHECKING([whether to enable breakpad])
+if test "$enable_breakpad" != yes; then
+ AC_MSG_RESULT([no])
+else
+ AC_MSG_RESULT([yes])
+ ENABLE_BREAKPAD="TRUE"
+ AC_DEFINE(ENABLE_BREAKPAD)
+ AC_DEFINE(HAVE_FEATURE_BREAKPAD, 1)
+ BUILD_TYPE="$BUILD_TYPE BREAKPAD"
+fi
+AC_SUBST(ENABLE_BREAKPAD)
+
dnl ===================================================================
dnl Orcus
dnl ===================================================================