summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJonathan Riddell <jr@jriddell.org>2014-11-22 20:36:09 +0100
committerJan Holesovsky <kendy@collabora.com>2014-11-22 21:49:22 +0000
commit9ddb055641271aa33fe9f470c739eab9d146a4c6 (patch)
tree0c685a595defa11e059728012a3ae4b6910140a1 /configure.ac
parentc63f17a7799b4b8f25b605101d6baea28a1f51be (diff)
Add Breeze icon theme for use with KDE Plasma 5
Change-Id: I936d31300126e2ce000ea3a7cd70c8a2dec19502 Reviewed-on: https://gerrit.libreoffice.org/13043 Reviewed-by: Jan Holesovsky <kendy@collabora.com> Tested-by: Jan Holesovsky <kendy@collabora.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 4 insertions, 4 deletions
diff --git a/configure.ac b/configure.ac
index 8f29ed60e6ae..05b19721c98e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1474,7 +1474,7 @@ AC_ARG_WITH(galleries,
AC_ARG_WITH(theme,
AS_HELP_STRING([--with-theme="theme1 theme2..."],
[Choose which themes to include. By default those themes with an '*' are included.
- Possible choices: *crystal, *galaxy, *hicontrast, human, industrial, *oxygen, *sifr, *tango, *tango_testing.]),
+ Possible choices: *breeze, *crystal, *galaxy, *hicontrast, human, industrial, *oxygen, *sifr, *tango, *tango_testing.]),
,)
AC_ARG_WITH(helppack-integration,
@@ -11372,7 +11372,7 @@ dnl ===================================================================
AC_MSG_CHECKING([which themes to include])
# if none given use default subset of available themes
if test "x$with_theme" = "x" -o "x$with_theme" = "xyes"; then
- with_theme="crystal galaxy hicontrast oxygen tango sifr"
+ with_theme="breeze crystal galaxy hicontrast oxygen tango sifr"
test -z "$ENABLE_RELEASE_BUILD" && with_theme="$with_theme tango_testing"
fi
@@ -11380,7 +11380,7 @@ WITH_THEMES=""
if test "x$with_theme" != "xno"; then
for theme in $with_theme; do
case $theme in
- crystal|galaxy|hicontrast|human|industrial|oxygen|sifr|tango|tango_testing) real_theme="$theme" ;;
+ breeze|crystal|galaxy|hicontrast|human|industrial|oxygen|sifr|tango|tango_testing) real_theme="$theme" ;;
default) real_theme=galaxy ;;
*) AC_MSG_ERROR([Unknown value for --with-theme: $theme]) ;;
esac
@@ -12638,7 +12638,7 @@ if test "$enable_mpl_subset" = "yes"; then
fi
for theme in $WITH_THEMES; do
case $theme in
- crystal|default|hicontrast|human|oxygen|sifr)
+ breeze|crystal|default|hicontrast|human|oxygen|sifr)
AC_MSG_ERROR([need to disable icon themes from '$WITH_THEMES': $theme present, use --with-theme=tango]) ;;
*) : ;;
esac