summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMarkus Mohrhard <markus.mohrhard@googlemail.com>2016-08-30 05:16:41 +0200
committerMarkus Mohrhard <markus.mohrhard@googlemail.com>2017-05-19 03:43:21 +0200
commit837af5b873137c1a561791e36f01378934d48271 (patch)
treee6c9da6130dfb5d43a4c1eb13eb40bc3622ded6f /configure.ac
parenta22e3305f13dd03520c957e1f19597f389e6cd3e (diff)
more steps in the direction of signed mar files
Change-Id: Ib6d5fbc00eeaa97b16599a1545c32188a3cd9720
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 17 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a5ad53b18e24..63334a7c4aa7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1382,11 +1382,22 @@ libo_FUZZ_ARG_ENABLE(online-update,
If the value is "mar", the experimental Mozilla-like update will be
enabled instead of the traditional update mechanism.]),
,)
+
AC_ARG_WITH(update-channel,
AS_HELP_STRING([--with-update-channel=master-daily],
[Defines the update channel used by the updater.]),
,with_update_channel=master-daily)
+AC_ARG_WITH(update-certificate-name,
+ AS_HELP_STRING([--with-update-certificate-name=master-daily],
+ [Defines the name of the certificate that should be used to sign the mar files.
+ This makes only sense if the onlineupdate is used and the mar files should be uploaded.]))
+
+AC_ARG_WITH(update-certificate-path,
+ AS_HELP_STRING([--with-update-certificate-name=master-daily],
+ [Defines the path to the nss certificate store used for the updater
+ This makes only sense if the onlineupdate is used and the mar files should be uploaded.]))
+
libo_FUZZ_ARG_ENABLE(extension-update,
AS_HELP_STRING([--disable-extension-update],
[Disable possibility to update installed extensions.]),
@@ -11308,6 +11319,8 @@ AC_MSG_CHECKING([whether to enable online update])
ENABLE_ONLINE_UPDATE=
ENABLE_ONLINE_UPDATE_MAR=
UPDATE_CHANNEL=
+UPDATE_CERTIFICATE_NAME=
+UPDATE_CERTIFICATE_PATH=
if test "$enable_online_update" = ""; then
if test "$_os" = "WINNT" -o "$_os" = "Darwin"; then
AC_MSG_RESULT([yes])
@@ -11321,6 +11334,8 @@ else
ENABLE_ONLINE_UPDATE_MAR="TRUE"
AC_DEFINE(HAVE_FEATURE_UPDATE_MAR)
UPDATE_CHANNEL="$with_update_channel"
+ UPDATE_CERTIFICATE_NAME="$with_update_certificate_name"
+ UPDATE_CERTIFICATE_PATH="$with_update_certificate_path"
elif test "$enable_online_update" = "yes"; then
AC_MSG_RESULT([yes])
ENABLE_ONLINE_UPDATE="TRUE"
@@ -11331,6 +11346,8 @@ fi
AC_SUBST(ENABLE_ONLINE_UPDATE)
AC_SUBST(ENABLE_ONLINE_UPDATE_MAR)
AC_SUBST(UPDATE_CHANNEL)
+AC_SUBST(UPDATE_CERTIFICATE_NAME)
+AC_SUBST(UPDATE_CERTIFICATE_PATH)
dnl ===================================================================
dnl Test whether we need bzip2