summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorCaolán McNamara <caolanm@redhat.com>2016-02-18 13:38:12 +0000
committerCaolán McNamara <caolanm@redhat.com>2016-02-18 15:48:31 +0000
commit548c2274c9ba7542d6bcae5fefd1400ee4e22fc3 (patch)
tree7963bec49ed00b89090bd213a7db36a85bc88f87 /configure.ac
parent423b79e7366203db3f57dea75b8cb9eb852b5614 (diff)
move from boost::signal to typed Link
it doesn't really gain us much to have a handful of boost::signal use in a sea of Links This also fixes a regression in commit 051b29e1025253f35f87a04e297760aa8b40611f Author: Luboš Luňák <l.lunak@collabora.com> Date: Sun Sep 14 15:45:02 2014 +0200 convert Edit autocomplete Hdl to boost signals2 where the conversion was... - if ( maAutocompleteHdl.IsSet() ) + if ( autocompleteSignal.empty() ) instead of the correct + if ( !autocompleteSignal.empty() ) Change-Id: I27270d94c782485c0a7e929bc4980af4527fe82b
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 0 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 315bffaf9ae6..daa1810cd6a6 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8761,11 +8761,6 @@ if test "$with_system_boost" = "yes"; then
[AC_MSG_ERROR(boost/spirit/include/classic_core.hpp not found. install boost >= 1.36)], [])
AC_CHECK_HEADER(boost/function.hpp, [],
[AC_MSG_ERROR(boost/function.hpp not found. install boost)], [])
- AC_MSG_CHECKING([whether boost signals2 works])
- AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <boost/signals2/signal.hpp>]],
- [[ boost::signals2::signal<void()> s; s(); ]])],
- [AC_MSG_RESULT([yes])],
- [AC_MSG_ERROR([no, install boost >= 1.55 or use --without-system-boost])])
CXXFLAGS="$CXXFLAGS -fno-exceptions"
AC_MSG_CHECKING([whether boost/function.hpp compiles with -fno-exceptions])
AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[#include <boost/function.hpp>