summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRene Engelhard <rene@debian.org>2015-12-12 11:36:25 +0100
committerThorsten Behrens <Thorsten.Behrens@CIB.de>2015-12-17 15:31:17 +0000
commit4c18af27bf95b332ee2006cfc0bbf469fb1a84d4 (patch)
tree5ff484eada8d6782b70c323a340bf197709ecc1e /configure.ac
parent57b1cf5862429d86a82158eb5e8cf425fd2f4527 (diff)
tdf#96398 kill remaining NPAPI support for plugins _inside_ LO
- probably out of date - links against Gtk2 and thus causes a GTk2 dependency in core packages - the only serious usecase (Flash) is doomed anyway Change-Id: I7264ab5eb04c2f4b6c31a815e45b9818209e5ae2 Reviewed-on: https://gerrit.libreoffice.org/20658 Reviewed-by: David Ostrovsky <david@ostrovsky.org> Reviewed-by: Bryan Quigley <gquigs@gmail.com> Tested-by: Thorsten Behrens <Thorsten.Behrens@CIB.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac78
1 files changed, 0 insertions, 78 deletions
diff --git a/configure.ac b/configure.ac
index 49198a8e8809..ecff3719f11f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1951,13 +1951,6 @@ AC_ARG_WITH(system-liblangtag,
[Use liblangtag library already on system.]),,
[with_system_liblangtag="$with_system_libs"])
-AC_ARG_WITH(system-npapi-headers,
- AS_HELP_STRING([--with-system-npapi-headers],
- [Use NPAPI headers provided by system instead of bundled ones. Used in
- extensions/source/plugin (ENABLE_NPAPI_FROM_BROWSER=TRUE)]),,
- [with_system_npapi_headers="$with_system_headers"]
-)
-
AC_ARG_WITH(jpeg-turbo,
AS_HELP_STRING([--with-jpeg-turbo],
[Use internal libjpeg-turbo library.]),,
@@ -8953,56 +8946,6 @@ if test $_os = WINNT -a -z "$ENABLE_RELEASE_BUILD" -a "$with_prebuilt_openssl" =
fi
dnl ===================================================================
-dnl Check for system mozilla headers
-dnl ===================================================================
-HAVE_NON_CONST_NPP_GETMIMEDESCRIPTION=
-AC_MSG_CHECKING([which NPAPI headers to use])
-
-if test "$with_system_npapi_headers" = "yes"; then
- AC_MSG_RESULT([external])
- SYSTEM_NPAPI_HEADERS=TRUE
- # First try npapi-sdk:
- PKG_CHECK_MODULES(NPAPI_HEADERS, npapi-sdk, [LOCATED=yes], [LOCATED=no])
- # Then go with libxul:
- if test "x$LOCATED" != "xyes"; then
- PKG_CHECK_MODULES(NPAPI_HEADERS, libxul, [LOCATED=yes], [LOCATED=no])
- fi
- if test "x$LOCATED" != "xyes"; then
- PKG_CHECK_MODULES(NPAPI_HEADERS, mozilla-plugin, [LOCATED=yes], [LOCATED=no])
- fi
- # if still not found bail out
- if test "x$LOCATED" != "xyes"; then
- AC_MSG_ERROR([npapi.h header file not found])
- fi
-
- AC_LANG_PUSH([C])
- save_CFLAGS=$CFLAGS
- CFLAGS="$CFLAGS $NPAPI_HEADERS_CFLAGS"
- AC_MSG_CHECKING([for NPP_GetMIMEDescription return type])
- AC_COMPILE_IFELSE(
- [AC_LANG_SOURCE([[
- #define XP_UNIX
- #include <npapi.h>
- const char* NPP_GetMIMEDescription(void) { return "foo"; }
- ]])],
- [AC_MSG_RESULT([const char*])],
- [
- AC_MSG_RESULT([char*])
- HAVE_NON_CONST_NPP_GETMIMEDESCRIPTION=TRUE
- ])
- CFLAGS=$save_CFLAGS
- AC_LANG_POP([C])
- NPAPI_HEADERS_CFLAGS=$(printf '%s' "$NPAPI_HEADERS_CFLAGS" | sed -e "s/-I/${ISYSTEM?}/g")
-else
- AC_MSG_RESULT([internal])
- dnl ...but will not be built/used unless ENABLE_NPAPI_FROM_BROWSER
- SYSTEM_NPAPI_HEADERS=
-fi
-AC_SUBST(NPAPI_HEADERS_CFLAGS)
-AC_SUBST(SYSTEM_NPAPI_HEADERS)
-AC_SUBST(HAVE_NON_CONST_NPP_GETMIMEDESCRIPTION)
-
-dnl ===================================================================
dnl Check for system sane
dnl ===================================================================
AC_MSG_CHECKING([which sane header to use])
@@ -9211,23 +9154,6 @@ else
fi
AC_SUBST(ENABLE_HARFBUZZ)
-dnl ===================================================================
-dnl Check for NPAPI interface to plug browser plugins into LibreOffice documents
-dnl ===================================================================
-AC_MSG_CHECKING([whether to plug browser plugins into LibreOffice documents])
-# Obviously no such thing on iOS or Android. Also not possible when building
-# 64-bit OS X code as the plugin code uses QuickTime and Carbon.
-if test "$_os" != Android -a "$_os" != iOS -a $_os != Darwin -a \
- "$with_x" != "no" -a "$enable_mpl_subset" != yes
-then
- AC_MSG_RESULT([yes])
- ENABLE_NPAPI_FROM_BROWSER=TRUE
-else
- AC_MSG_RESULT([no])
- ENABLE_NPAPI_FROM_BROWSER=
-fi
-AC_SUBST(ENABLE_NPAPI_FROM_BROWSER)
-
AC_MSG_CHECKING([whether to use X11])
dnl ***************************************
dnl testing for X libraries and includes...
@@ -9263,10 +9189,6 @@ if test "$USING_X11" = TRUE; then
AC_CHECK_HEADERS(X11/Composite.h,[],[AC_MSG_ERROR([Xt headers not found])],
[#include <X11/Intrinsic.h>])
- # ENABLE_NPAPI_FROM_BROWSER requires Xt library
- AC_CHECK_LIB([Xt], [XtToolkitInitialize], [:],
- [AC_MSG_ERROR(Xt library not found)])
-
dnl ===================================================================
dnl Check for extension headers
dnl ===================================================================