summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChristian Lohmaier <lohmaier+LibreOffice@googlemail.com>2017-09-07 18:27:12 +0200
committerChristian Lohmaier <lohmaier+LibreOffice@googlemail.com>2017-09-12 12:04:09 +0200
commit3de5cd341d861faeadabec16ff675d764f8df4b6 (patch)
treebefcfed7eb4478badc702cc95ff56d17f90a3288 /configure.ac
parent8c1140e6230d14604f17030e22986e338510174c (diff)
android: tune symbols for lldb & we actually target 14 as minSDK
-glldb might be placebo switch like -ggdb2, but at last it won't hurt :-) increase java heap size for gradle to allow inprocess dex as well as actually processing the huge files. furthermore fix platform level in configure to match the minSDK value from build.gradle Change-Id: I57d7d4c67bc3e5ed8bfed1e592b85211b5b8905a Reviewed-on: https://gerrit.libreoffice.org/42162 Reviewed-by: Christian Lohmaier <lohmaier+LibreOffice@googlemail.com> Tested-by: Jenkins <ci@libreoffice.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 4 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index f053df0192c7..f616afef856e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -474,18 +474,15 @@ if test -n "$with_android_ndk"; then
fi
fi
- ANDROID_API_LEVEL=15
+ ANDROID_API_LEVEL=14
if test $host_cpu = arm; then
android_gnu_prefix=arm-linux-androideabi
elif test $host_cpu = aarch64; then
android_gnu_prefix=aarch64-linux-android
ANDROID_NDK_TOOLCHAIN_VERSION_SUBDIR="${with_android_ndk_toolchain_version}/"
- ANDROID_API_LEVEL=L
+ ANDROID_API_LEVEL=21
elif test $host_cpu = mips; then
android_gnu_prefix=mipsel-linux-android
- elif test $ANDROID_NDK_VERSION = r8; then
- # The prefix used for the x86 tool-chain changed between NDK r8 and r8b
- android_gnu_prefix=i686-android-linux
else
android_gnu_prefix=i686-linux-android
fi
@@ -850,7 +847,7 @@ linux-android*)
;;
esac
-if echo "$host_os" | grep -q linux-android ; then
+if test "$_os" = "Android" ; then
if test -z "$with_android_sdk"; then
AC_MSG_ERROR([the --with-android-sdk option is mandatory, unless it is available at external/android-sdk-linux/.])
fi
@@ -11883,7 +11880,7 @@ else
fi
AC_SUBST(OOO_VENDOR)
-if echo "$host_os" | grep -q linux-android ; then
+if test "$_os" = "Android" ; then
ANDROID_PACKAGE_NAME=
AC_MSG_CHECKING([for Android package name])
if test -z "$with_android_package_name" -o "$with_android_package_name" = "no"; then