summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Stahl <mstahl@redhat.com>2014-10-02 18:15:41 +0200
committerMichael Stahl <mstahl@redhat.com>2014-10-02 20:00:18 +0200
commit3b59dbbffdb73e48f9e2398bb1eecc24e3d95e13 (patch)
tree8b58bba8c42110e10f6763b598f294bf7359b1f0 /configure.ac
parent86cd29772e4f0571149c479378164572fbc96034 (diff)
remove HAVE_GCC_PRAGMA_DIAGNOSTIC_SCOPE check and macro
This is supported in GCC 4.6.0 already: https://gcc.gnu.org/onlinedocs/gcc-4.6.0/gcc/Diagnostic-Pragmas.html Change-Id: I2f67e588eea3a323a2e9c81e39e56ab2e715a817
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 0 insertions, 14 deletions
diff --git a/configure.ac b/configure.ac
index 44ee065d2a58..f14180a5e5f7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5789,20 +5789,6 @@ if test "$GCC" = "yes"; then
AC_MSG_RESULT([no])
fi
- AC_MSG_CHECKING([whether $CC supports pragma GCC diagnostic push/pop])
- save_CFLAGS=$CFLAGS
- CFLAGS="$CFLAGS -Werror -Wunknown-pragmas -Wunused-parameter"
- AC_COMPILE_IFELSE([AC_LANG_SOURCE([
- #pragma GCC diagnostic push
- #pragma GCC diagnostic ignored "-Wunused-parameter"
- void dummy(int n) {}
- #pragma GCC diagnostic pop
- ])], [
- AC_DEFINE([HAVE_GCC_PRAGMA_DIAGNOSTIC_SCOPE],[1])
- AC_MSG_RESULT([yes])
- ], [AC_MSG_RESULT([no])])
- CFLAGS=$save_CFLAGS
-
AC_MSG_CHECKING([whether $CC supports __attribute__((deprecated(message)))])
save_CFLAGS=$CFLAGS
CFLAGS="$CFLAGS -Werror"