summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSamuel Mehrbrodt <Samuel.Mehrbrodt@cib.de>2017-09-15 14:02:07 +0200
committerMichael Stahl <mstahl@redhat.com>2017-09-15 20:57:36 +0200
commit15966e0721af1d16243a032ec2832a66a069de93 (patch)
tree985fd77a0ef997cb4928b0fcc72c161927b0b11d /configure.ac
parent894115b5739b48fc241f8cd5f9f7a1830161a22d (diff)
al.exe not found on Windows 10 with VS 2017
Change-Id: I091c0cb9a33d5b52dfb34e54515d6c283d6efb96 Reviewed-on: https://gerrit.libreoffice.org/42323 Tested-by: Jenkins <ci@libreoffice.org> Reviewed-by: Michael Stahl <mstahl@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 8 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 00fc1aee1b0d..5f72318268ce 100644
--- a/configure.ac
+++ b/configure.ac
@@ -5015,13 +5015,19 @@ find_al()
fi
done
- # We need this additional check to detect 4.6.2 or above.
- for ver in 4.7 4.6.2; do
+ # We need this additional check to detect 4.6.1 or above.
+ for ver in 4.7 4.6.2 4.6.1; do
reg_get_value_32 "HKEY_LOCAL_MACHINE/SOFTWARE/Microsoft/Microsoft SDKs/NETFXSDK/$ver/WinSDK-NetFx40Tools/InstallationFolder"
if test -n "$regvalue" -a \( -f "$regvalue/al.exe" -o -f "$regvalue/bin/al.exe" \); then
altest=$regvalue
return
fi
+
+ reg_get_value_32 "HKEY_LOCAL_MACHINE/SOFTWARE/WOW6432Node/Microsoft/Microsoft SDKs/NETFXSDK/$ver/WinSDK-NetFx40Tools"
+ if test -n "$regvalue" -a \( -f "$regvalue/al.exe" -o -f "$regvalue/bin/al.exe" \); then
+ altest=$regvalue
+ return
+ fi
done
}