summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTor Lillqvist <tml@collabora.com>2013-12-17 14:13:35 +0200
committerTor Lillqvist <tml@collabora.com>2013-12-17 14:22:11 +0200
commit13b73d94dc2f6fc707e94eb58aee449494128d82 (patch)
tree60a99d41ede56ce146729e1242c250ab885eea88 /configure.ac
parentfa66ae3a739594da13fb78638ef98a2c8cc5ed2e (diff)
Pass also Xcode's ARCHS, OTHER_CFLAGS and OTHER_CPLUSPLUSFLAGS in lo.xcconfig
ARCHS tells Xcode to build the architecture for which the LO code has been built. The CFLAGS properties make sure the same -D flags are used as for the LO code. Change-Id: I3c8af0ff9fba7d0b4eddbc0af9aad44fb385314c
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 7 insertions, 6 deletions
diff --git a/configure.ac b/configure.ac
index 0c58a9cf81be..ab86c34d17c9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2973,10 +2973,10 @@ if test $_os = iOS; then
if test "$enable_ios_simulator" = yes; then
if test "$BITNESS_OVERRIDE" = 64; then
- arch=x86_64
+ XCODE_ARCHS=x86_64
versionmin=-mios-simulator-version-min=7.0
else
- arch=i386
+ XCODE_ARCHS=i386
case $sdkver in
7.*)
versionmin=-mios-simulator-version-min=6.1
@@ -2989,10 +2989,10 @@ if test $_os = iOS; then
else
platform=iPhoneOS
if test "$BITNESS_OVERRIDE" = 64; then
- arch=arm64
+ XCODE_ARCHS=arm64
versionmin=-miphoneos-version-min=7.0
else
- arch=armv7
+ XCODE_ARCHS=armv7
versionmin=-miphoneos-version-min=6.1
fi
fi
@@ -3023,8 +3023,8 @@ if test $_os = iOS; then
stdlib="-stdlib=$XCODE_CLANG_CXX_LIBRARY"
- CC="`xcrun -find clang` -arch $arch -fvisibility=hidden -isysroot $sysroot $lto $versionmin"
- CXX="`xcrun -find clang++` -arch $arch -fvisibility=hidden $stdlib -isysroot $sysroot $lto $versionmin"
+ CC="`xcrun -find clang` -arch $XCODE_ARCHS -fvisibility=hidden -isysroot $sysroot $lto $versionmin"
+ CXX="`xcrun -find clang++` -arch $XCODE_ARCHS -fvisibility=hidden $stdlib -isysroot $sysroot $lto $versionmin"
INSTALL_NAME_TOOL=`xcrun -find install_name_tool`
AR=`xcrun -find ar`
@@ -3035,6 +3035,7 @@ if test $_os = iOS; then
fi
AC_SUBST(XCODE_CLANG_CXX_LIBRARY)
+AC_SUBST(XCODE_ARCHS)
AC_MSG_CHECKING([whether to treat the installation as read-only])