summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorGeorge Kiagiadakis <george.kiagiadakis@collabora.co.uk>2011-01-06 22:05:23 +0200
committerGeorge Kiagiadakis <george.kiagiadakis@collabora.co.uk>2011-01-06 22:05:23 +0200
commit86725fc8d6475279d50ac0a86cd0271dc971ce83 (patch)
tree7de6bb74dfe0f2acd66df6704af58aa09971a39a /src/CMakeLists.txt
parente43f0c3f28086fd070db60ea24cedb68b80a0f69 (diff)
Implement a new way of wraping objects, similar to the one glibmm uses.
Features: * C++ wrappers are reused among several RefPointer instances. * C++ wrappers are even saved in qdata where applicable, to make sure they are only created once for each object. (This does not apply to MiniObjects and Caps though) * dynamicCast should be faster in certain cases, since it no longer queries the GType of the instance if it is not necessary.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 066d8e7..ff32b14 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -7,6 +7,8 @@ set(QtGstreamer_SRCS
QGlib/signal.cpp
QGlib/error.cpp
QGlib/connect.cpp
+ QGlib/wrap.cpp
+ QGlib/init.cpp
QGst/global.cpp
QGst/objectstore.cpp
@@ -48,6 +50,7 @@ set(INSTALLED_HEADERS
QGlib/quark.h QGlib/Quark
QGlib/type.h QGlib/Type
QGlib/refpointer.h QGlib/RefPointer
+ QGlib/wrap.h
QGlib/paramspec.h QGlib/ParamSpec
QGlib/object.h QGlib/Object
QGlib/value.h QGlib/Value