summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorMauricio Piacentini <mauricio.piacentini@collabora.co.uk>2010-11-24 21:48:22 -0200
committerMauricio Piacentini <mauricio.piacentini@collabora.co.uk>2010-11-24 22:06:20 -0200
commit707766184b2609451041157eef272aed35a61178 (patch)
treec0a655161703c0b585e06c13f436a8840d2b259d /src/CMakeLists.txt
parenta8f6be2b1e2fb6f215df526b60697913bb789db0 (diff)
Add global object store to track the bindings reference count for MiniObjects and Caps. With this change the bindings only keep one external reference to these objects, avoiding the mutability problem with temporaries and when two C++ objects refer to the same miniobject. Works around bug 510301 at Gstreamer's bugzilla
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index e9e5450..52d516b 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -8,6 +8,7 @@ set(QtGstreamer_SRCS
QGlib/error.cpp
QGst/global.cpp
+ QGst/objectstore.cpp
QGst/structs.cpp
QGst/structure.cpp
QGst/caps.cpp