summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorGeorge Kiagiadakis <george.kiagiadakis@collabora.com>2014-06-24 12:21:07 +0300
committerGeorge Kiagiadakis <george.kiagiadakis@collabora.com>2014-06-24 12:21:07 +0300
commit478d5c8fd71be218e37b2b3a9fd7e5c8ec5b08b7 (patch)
tree52cf93dc77d62893d7a6623c4af0573703fcdf73 /src/CMakeLists.txt
parentd009b84dcb60fca1a41a3e908bdb73a3f33bb38f (diff)
build system: install .pc file and cmake variables for the Qt5GStreamerQuick library
... and fix the qmlplayer2 .pro file to test it. "make examples_distcheck" passes at this point.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt9
1 files changed, 6 insertions, 3 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 1d5f516..c0011df 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -85,7 +85,10 @@ foreach(pc_in_file ${PC_IN_FILES})
if (USE_QT5)
string(REPLACE "Qt" "Qt5" pc_out_file ${pc_out_file})
endif()
- configure_file(${pc_in_file} ${CMAKE_CURRENT_BINARY_DIR}/${pc_out_file} @ONLY)
- install(FILES ${CMAKE_CURRENT_BINARY_DIR}/${pc_out_file}
- DESTINATION ${QTGSTREAMER_PC_INSTALL_DIR})
+ # Qt4 version of the QtGStreamerQuick .pc file should not be installed
+ if (NOT ${pc_out_file} MATCHES "QtGStreamerQuick.*")
+ configure_file(${pc_in_file} ${CMAKE_CURRENT_BINARY_DIR}/${pc_out_file} @ONLY)
+ install(FILES ${CMAKE_CURRENT_BINARY_DIR}/${pc_out_file}
+ DESTINATION ${QTGSTREAMER_PC_INSTALL_DIR})
+ endif()
endforeach()