summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorGeorge Kiagiadakis <george.kiagiadakis@collabora.com>2013-06-07 13:12:02 +0300
committerGeorge Kiagiadakis <george.kiagiadakis@collabora.com>2013-06-09 19:20:26 +0300
commit42015febada2f0122409db9a85c3948f6892b02f (patch)
treea4af717f525da8177963ce488a9a60d32e59f906 /src/CMakeLists.txt
parent51687fe4408bd3aa6f7a88c7eebb0b6ffd2e98c7 (diff)
cmake: Replace QtHelpers by a better FindQt4or5 script
This script makes use of qt4_use_modules and qt5_use_modules, which allow us to get rid of QT_* variables in cmake code and also do things right by defining all the necessary include directories and required Qt defines as well as compiler flags. This also allows us to support both Qt4 and Qt5 in the examples when compiled standalone without much effort.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index d680cf1..885e526 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -50,8 +50,8 @@ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${QTGSTREAMER_FLAGS}")
add_subdirectory(QGlib)
add_subdirectory(QGst)
-# Build the qml plugin
-if (QT_QTDECLARATIVE_FOUND)
+# Build the QtQuick1 plugin
+if (Qt4or5_Quick1_FOUND)
add_subdirectory(qml)
endif()