summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorGeorge Kiagiadakis <george.kiagiadakis@collabora.com>2012-01-16 01:33:01 +0200
committerGeorge Kiagiadakis <george.kiagiadakis@collabora.com>2012-01-16 01:33:01 +0200
commit1790311bcf7b53ef2d36f8c72b2875edc66e4b33 (patch)
treea46b5742018b31821d7306fcebca12236ab44b7f /src/CMakeLists.txt
parenta12aea13b9d4b90ff2f1e84b7f59849cad8c0203 (diff)
Add a qml plugin that exports GraphicsVideoWidget as a QML item called "VideoItem"
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index f8d9505..3822449 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -50,6 +50,11 @@ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${QTGSTREAMER_FLAGS}")
add_subdirectory(QGlib)
add_subdirectory(QGst)
+# Build the qml plugin
+if (QT_QTDECLARATIVE_FOUND)
+ add_subdirectory(qml)
+endif()
+
# Install the cmake scripts that are used to find the installed library from external projects
install(EXPORT ${EXPORT_TARGET_SET} DESTINATION ${LIB_INSTALL_DIR}/QtGStreamer)
install(FILES ${CMAKE_SOURCE_DIR}/cmake/modules/FindQtGStreamer.cmake