summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorGeorge Kiagiadakis <george.kiagiadakis@collabora.co.uk>2010-12-08 12:53:22 +0200
committerGeorge Kiagiadakis <george.kiagiadakis@collabora.co.uk>2010-12-08 12:53:22 +0200
commit0a8d2c5443482f137ca22cda434f66ad68920d9d (patch)
tree55a5ee801e0ed0fa618090d5b2eff93b21b1e3df /src/CMakeLists.txt
parent7122d6862ab1fbdde8ec74a599abb9299ce0f34e (diff)
Use an alternative way to get rid of the libxml2 dependency.
Defining GST_DISABLE_DEPRECATED is not good for a release, since the code will break every time gstreamer upstream deprecates new methods. By defining GST_DISABLE_LOADSAVE, all xml-related methods are omitted in the gstreamer headers, and by defining GST_DISABLE_XML, gstconfig.h skips inclusion of <libxml/parser.h>, thus we get the same effect without disabling all deprecated methods.
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 2a1aba3..8f8785e 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -139,7 +139,7 @@ set(CODEGEN_INCLUDES
include_directories(${CMAKE_CURRENT_BINARY_DIR} ${GSTREAMER_INCLUDE_DIR}
${GSTREAMER_INTERFACES_INCLUDE_DIR}
${GLIB2_INCLUDE_DIR} ${QTGSTREAMER_INCLUDES})
-add_definitions(${QTGSTREAMER_DEFINITIONS} -DGST_DISABLE_DEPRECATED)
+add_definitions(${QTGSTREAMER_DEFINITIONS} -DGST_DISABLE_XML -DGST_DISABLE_LOADSAVE)
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${QTGSTREAMER_FLAGS}")