summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorNicolas Dufresne <nicolas.dufresne@collabora.com>2021-09-24 14:11:13 -0400
committerThibault Saunier <tsaunier@igalia.com>2021-09-24 17:47:01 -0300
commit3037fde5ebddf3d755d29b4f06f21e6ca122d484 (patch)
treefa88032ccbf34d03c5cbd56b52073cfa6ef9cb8b /meson.build
parent776d8a661720b05861ab797cca01ef37fdaf6b78 (diff)
Move commit gst-indent hook to the rootmonorepo-start
This renable at meson setup time the installation of the gst-indent commit hook. The hooks were kept from gst-devtools as this set supports both C checks and Python checks. Part-of: <https://gitlab.freedesktop.org/gstreamer/gstreamer/-/merge_requests/904>
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index b2709bd91d..dcc1fbae71 100644
--- a/meson.build
+++ b/meson.build
@@ -24,6 +24,9 @@ if cmdres.returncode() != 0
error('Do not run `ninja` or `meson` for gst-build inside the uninstalled environment, you will run into problems')
endif
+# Install gst-indent pre-commit hook
+run_command(python3, '-c', 'import shutil; shutil.copy("scripts/git-hooks/multi-pre-commit.hook", ".git/hooks/pre-commit")')
+
# Ensure that the user does not have Strawberry Perl in PATH, since it ships
# with a pkg-config.bat and broken pkgconfig files for libffi and zlib. Will
# cause a build error, such as in