summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim.muller@collabora.co.uk>2009-08-05 13:25:33 +0100
committerTim-Philipp Müller <tim.muller@collabora.co.uk>2009-08-06 09:21:56 +0100
commitcc57c404fd722cfe47f337b645e26197baab4c97 (patch)
tree4d70ff7635d87903dc77143025492d2ff154984e /configure.ac
parent19847e19569ad8d33676cbabe3beb080e9922569 (diff)
configure.ac: fix libxml2 check, which is only needed for xml load/save now
Since the registry doesn't use libxml2 any longer, it's no longer necessary to disable both xml load/save *and* the registry to get rid of the libxml2 dependency, disabling just xml loading/saving is enough. Fixes #590841.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 4fd55f0523..49bfff962d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -491,8 +491,8 @@ dnl Check for documentation xrefs
GLIB_PREFIX="`$PKG_CONFIG --variable=prefix glib-2.0`"
AC_SUBST(GLIB_PREFIX)
-dnl libxml 2 is optional in some cases
-if test "x$GST_DISABLE_LOADSAVE" = "xyes" -a "x$GST_DISABLE_REGISTRY" = "xyes"
+dnl libxml2 is only needed for xml loading/saving of pipelines these days
+if test "x$GST_DISABLE_LOADSAVE" = "xyes"
then
AC_MSG_NOTICE([XML registry and load/save are disabled, not checking for libxml2])
GST_DISABLE_XML_DEFINE="#define GST_DISABLE_XML 1"