summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTim-Philipp Müller <tim.muller@collabora.co.uk>2010-04-25 16:35:30 +0100
committerTim-Philipp Müller <tim.muller@collabora.co.uk>2010-04-25 16:35:59 +0100
commitb0c6a9aa339856fe2522d6c158e21b9e6f661d9e (patch)
tree7c7545011441252aa4b54b6c9721b9fec23b2fdf /configure.ac
parent336ffc0941308597105f4cd3bc8c1cb497b38108 (diff)
configure: fail if GStreamer core/base requirements are not met
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 3 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 0218fd2..84446f9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -40,10 +40,6 @@ dnl *** required versions of GStreamer stuff ***
GST_REQ=0.10.28.1
GSTPB_REQ=0.10.28.1
-dnl export for .pc files
-AC_SUBST([GST_REQ])
-AC_SUBST([GSTPB_REQ])
-
dnl *** autotools stuff ****
dnl allow for different autotools
@@ -155,7 +151,7 @@ AG_GST_GLIB_CHECK([$GLIB_REQ])
dnl checks for gstreamer
dnl uninstalled is selected preferentially -- see pkg-config(1)
-AG_GST_CHECK_GST($GST_MAJORMINOR, [$GST_REQ])
+AG_GST_CHECK_GST($GST_MAJORMINOR, [$GST_REQ], [yes])
GST_TOOLS_DIR=`$PKG_CONFIG --variable=toolsdir gstreamer-$GST_MAJORMINOR`
if test -z $GST_TOOLS_DIR; then
@@ -167,9 +163,9 @@ GST_PLUGINS_DIR=`$PKG_CONFIG gstreamer-$GST_MAJORMINOR --variable pluginsdir`
AC_SUBST(GST_PLUGINS_DIR)
AC_MSG_NOTICE(Using GStreamer Core Plugins in $GST_PLUGINS_DIR)
-AG_GST_CHECK_GST_BASE($GST_MAJORMINOR, [$GST_REQ])
+AG_GST_CHECK_GST_BASE($GST_MAJORMINOR, [$GST_REQ], [yes])
-AG_GST_CHECK_GST_PLUGINS_BASE($GST_MAJORMINOR, [$GSTPB_REQ])
+AG_GST_CHECK_GST_PLUGINS_BASE($GST_MAJORMINOR, [$GSTPB_REQ], [yes])
GSTPB_PLUGINS_DIR=`$PKG_CONFIG gstreamer-plugins-base-$GST_MAJORMINOR --variable pluginsdir`
AC_SUBST(GSTPB_PLUGINS_DIR)
AC_MSG_NOTICE(Using GStreamer Base Plugins in $GSTPB_PLUGINS_DIR)