summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Schleef <ds@schleef.org>2010-06-08 15:23:28 -0700
committerDavid Schleef <ds@schleef.org>2010-06-08 17:25:34 -0700
commitd9817d5ec009d319b556b73e875c206367039c07 (patch)
tree3282f4d352bfb841be2641f17c7ad99f74dfd054 /configure.ac
parent44c911d255a7a3596c2cdbf0d779cce34684d68a (diff)
configure: Add orc check
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac28
1 files changed, 28 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 739a4dc2f..fe72587ed 100644
--- a/configure.ac
+++ b/configure.ac
@@ -210,7 +210,35 @@ dnl liboil is required
PKG_CHECK_MODULES(LIBOIL, liboil-0.3 >= 0.3.8, HAVE_LIBOIL=yes, HAVE_LIBOIL=no)
if test "x$HAVE_LIBOIL" != "xyes"; then
AC_ERROR([liboil-0.3.8 or later is required])
+
+dnl Orc
+AC_ARG_ENABLE(orc,
+AC_HELP_STRING([--enable-orc],[use Orc if installed]),
+[case "${enableval}" in
+ yes) enable_orc=yes ;;
+ no) enable_orc=no ;;
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-orc) ;;
+esac
+],
+[enable_orc=yes]) dnl Default value
+
+ORC_REQ=0.4.5
+if test "x$enable_orc" = "xyes" ; then
+ PKG_CHECK_MODULES(ORC, orc-0.4 >= $ORC_REQ, [
+ AC_DEFINE(HAVE_ORC, 1, [Use Orc])
+ ORCC=`$PKG_CONFIG --variable=orcc orc-0.4`
+ AC_SUBST(ORCC)
+ HAVE_ORC=yes
+ ], [
+ AC_DEFINE(DISABLE_ORC, 1, [Disable Orc])
+ HAVE_ORC=no
+ ])
+else
+ AC_DEFINE(DISABLE_ORC, 1, [Disable Orc])
+ HAVE_ORC=no
fi
+AM_CONDITIONAL(HAVE_ORC, test "x$HAVE_ORC" = "xyes")
+
dnl checks for gstreamer
dnl uninstalled is selected preferentially -- see pkg-config(1)