summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorPierre-Louis Bossart <pierre-louis.bossart@intel.com>2010-06-01 18:54:41 -0500
committerSebastian Dröge <sebastian.droege@collabora.co.uk>2010-06-02 13:47:06 +0200
commit66a76d1f65141ec1180809d2fc258b1e4ecb9768 (patch)
treeb3736ab85e0c9914dcd949104519fd34278ca401 /configure.ac
parentf5057a9fae0caf6f2a65af27ce73fd80338cb48d (diff)
pulsesink: optimize communication with PulseAudio using pa_stream_begin_write
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index d69031a81..7782f163e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -803,6 +803,10 @@ AG_GST_CHECK_FEATURE(PULSE, [pulseaudio plug-in], pulseaudio, [
if test x$HAVE_PULSE_0_9_15 = xyes; then
AC_DEFINE(HAVE_PULSE_0_9_15, 1, [defined if pulseaudio >= 0.9.15 is available])
fi
+ AG_GST_PKG_CHECK_MODULES(PULSE_0_9_16, libpulse >= 0.9.16)
+ if test x$HAVE_PULSE_0_9_16 = xyes; then
+ AC_DEFINE(HAVE_PULSE_0_9_16, 1, [defined if pulseaudio >= 0.9.16 is available])
+ fi
AG_GST_PKG_CHECK_MODULES(PULSE_0_9_20, libpulse >= 0.9.20)
if test x$HAVE_PULSE_0_9_20 = xyes; then
AC_DEFINE(HAVE_PULSE_0_9_20, 1, [defined if pulseaudio >= 0.9.20 is available])