summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Schleef <ds@schleef.org>2010-06-09 18:37:29 -0700
committerDavid Schleef <ds@schleef.org>2010-06-09 18:37:29 -0700
commit269686fe35933286d6df38318ae82cc3fd0d2e91 (patch)
tree95907b19544d8c1217a49cb3bc5a330f4d455ef3 /configure.ac
parent823a514161747fb05a39054283570469d40d6d58 (diff)
configure: use m4 macro to check for Orc
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac29
1 files changed, 3 insertions, 26 deletions
diff --git a/configure.ac b/configure.ac
index 071bd3d8f..8620d8ae2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -207,32 +207,7 @@ dnl GLib is required
AG_GST_GLIB_CHECK([2.18])
dnl Orc
-AC_ARG_ENABLE(orc,
-AC_HELP_STRING([--enable-orc],[use Orc if installed]),
-[case "${enableval}" in
- yes) enable_orc=yes ;;
- no) enable_orc=no ;;
- *) AC_MSG_ERROR(bad value ${enableval} for --enable-orc) ;;
-esac
-],
-[enable_orc=yes]) dnl Default value
-
-ORC_REQ=0.4.5
-if test "x$enable_orc" = "xyes" ; then
- PKG_CHECK_MODULES(ORC, orc-0.4 >= $ORC_REQ, [
- AC_DEFINE(HAVE_ORC, 1, [Use Orc])
- ORCC=`$PKG_CONFIG --variable=orcc orc-0.4`
- AC_SUBST(ORCC)
- HAVE_ORC=yes
- ], [
- AC_DEFINE(DISABLE_ORC, 1, [Disable Orc])
- HAVE_ORC=no
- ])
-else
- AC_DEFINE(DISABLE_ORC, 1, [Disable Orc])
- HAVE_ORC=no
-fi
-AM_CONDITIONAL(HAVE_ORC, test "x$HAVE_ORC" = "xyes")
+ORC_CHECK([0.4.5])
dnl checks for gstreamer
@@ -1248,3 +1223,5 @@ sed \
AC_OUTPUT
AG_GST_OUTPUT_PLUGINS
+ORC_OUTPUT
+