summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBenjamin Otte <otte@redhat.com>2010-03-10 21:01:20 +0100
committerBenjamin Otte <otte@redhat.com>2010-03-10 21:01:20 +0100
commit96ef7c0d15600c17210ebf211e973fda90d73615 (patch)
tree3cccfda7650145fd2dd3898949bebbd762585d44 /configure.ac
parent801fdc2768ddd6093feb1f71e598ff3369a9ddf4 (diff)
Update for recent changes to common submodule
This just replaces every "$ERROR_CFLAGS" usage with a usage of "$WARNING_CFLAGS $ERROR_CFLAGS" to get the same functionality as previously. Actually using that separation will happen later.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d513e13be..09df3a68d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -786,7 +786,7 @@ AC_SUBST(DEPRECATED_CFLAGS)
dnl every flag in GST_OPTION_CFLAGS and GST_OPTION_CXXFLAGS can be overridden
dnl at make time with e.g. make ERROR_CFLAGS=""
-GST_OPTION_CFLAGS="\$(ERROR_CFLAGS) \$(DEBUG_CFLAGS) \$(PROFILE_CFLAGS) \$(GCOV_CFLAGS) \$(OPT_CFLAGS) \$(DEPRECATED_CFLAGS)"
+GST_OPTION_CFLAGS="\$(WARNING_CFLAGS) \$(ERROR_CFLAGS) \$(DEBUG_CFLAGS) \$(PROFILE_CFLAGS) \$(GCOV_CFLAGS) \$(OPT_CFLAGS) \$(DEPRECATED_CFLAGS)"
GST_OPTION_CXXFLAGS="\$(ERROR_CXXFLAGS) \$(DEBUG_CFLAGS) \$(PROFILE_CFLAGS) \$(GCOV_CFLAGS) \$(OPT_CFLAGS) \$(DEPRECATED_CFLAGS)"
AC_SUBST(GST_OPTION_CFLAGS)
AC_SUBST(GST_OPTION_CXXFLAGS)