summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBenjamin Otte <otte@redhat.com>2010-03-17 10:53:21 +0100
committerBenjamin Otte <otte@redhat.com>2010-03-17 12:09:25 +0100
commit1471df894adea8b74be7f7d6f0df66f278f1ad50 (patch)
tree96f2b4b77b964264d89736ac12edae9993b34d52 /configure.ac
parent20c9b8eae3457b5860fc8f477fe30aba9905c720 (diff)
Add -Wformat-nonliteral -Wformat-security
And fix the resulting compile failures. I'm sorry about the patch necessary to gstclockoverlay.h but after talking to Tim we decided we can live with it.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index cdac02c6b..11610d54f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -308,10 +308,11 @@ dnl set location of plugin directory
AG_GST_SET_PLUGINDIR
dnl define an ERROR_CFLAGS Makefile variable
-AG_GST_SET_ERROR_CFLAGS($GST_GIT, [-Wmissing-declarations -Wmissing-prototypes -Wredundant-decls -Wundef -Wwrite-strings])
+dnl -Wformat-nonliteral - see ext/pango/gstclockoverlay.c and http://gcc.gnu.org/bugzilla/show_bug.cgi?id=39438
+AG_GST_SET_ERROR_CFLAGS($GST_GIT, [-Wmissing-declarations -Wmissing-prototypes -Wredundant-decls -Wundef -Wwrite-strings -Wformat-nonliteral -Wformat-security])
dnl define an ERROR_CXXFLAGS Makefile variable
-AG_GST_SET_ERROR_CXXFLAGS($GST_GIT, [-Wmissing-declarations -Wmissing-prototypes -Wredundant-decls -Wundef -Wwrite-strings])
+AG_GST_SET_ERROR_CXXFLAGS($GST_GIT, [-Wmissing-declarations -Wmissing-prototypes -Wredundant-decls -Wundef -Wwrite-strings -Wformat-nonliteral -Wformat-security])
dnl define correct level for debugging messages
AG_GST_SET_LEVEL_DEFAULT($GST_GIT)