summaryrefslogtreecommitdiff
path: root/ext/schroedinger/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ext/schroedinger/Makefile.am')
-rw-r--r--ext/schroedinger/Makefile.am27
1 files changed, 27 insertions, 0 deletions
diff --git a/ext/schroedinger/Makefile.am b/ext/schroedinger/Makefile.am
new file mode 100644
index 000000000..23869243a
--- /dev/null
+++ b/ext/schroedinger/Makefile.am
@@ -0,0 +1,27 @@
+
+plugin_LTLIBRARIES = libgstschro.la
+
+noinst_HEADERS = \
+ gstschroutils.h
+
+libgstschro_la_SOURCES = \
+ gstschro.c \
+ gstschrodec.c \
+ gstschroenc.c \
+ gstschroparse.c \
+ gstschroutils.c
+libgstschro_la_CFLAGS = \
+ $(GST_CFLAGS) \
+ $(GST_BASE_CFLAGS) \
+ $(GST_PLUGINS_BASE_CFLAGS) \
+ $(SCHRO_CFLAGS)
+libgstschro_la_LIBADD = \
+ $(GST_LIBS) \
+ $(GST_BASE_LIBS) -lgstvideo-@GST_MAJORMINOR@ \
+ $(top_builddir)/gst-libs/gst/video/libgstbasevideo-@GST_MAJORMINOR@.la \
+ $(GST_PLUGINS_BASE_LIBS) \
+ $(SCHRO_LIBS)
+libgstschro_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+libgstschro_la_LIBTOOLFLAGS = --tag=disable-static
+
+