summaryrefslogtreecommitdiff
path: root/tests/examples/Makefile.am
diff options
context:
space:
mode:
authorVivia Nikolaidou <vivia@toolsonair.com>2017-01-16 19:36:07 +0200
committerSebastian Dröge <sebastian@centricular.com>2017-02-23 21:02:44 +0200
commitfa47edf84698ffd8a62e5c72ff2ef918f3fe30f0 (patch)
tree09b6d343c703cee57dc03d4c533f133bb6302d50 /tests/examples/Makefile.am
parentfc2ca69c2563a85c05fa4d04faf932d4df77645a (diff)
audiomixmatrix: New element that mixes audio channels
This element transforms a given number of input channels into a given number of output channels according to a given transformation matrix. The matrix coefficients must be between -1 and 1. In the auto mode, input/output channels are automatically negotiated and the transformation matrix is a truncated or zero-padded identity matrix. https://bugzilla.gnome.org/show_bug.cgi?id=777376
Diffstat (limited to 'tests/examples/Makefile.am')
-rw-r--r--tests/examples/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/tests/examples/Makefile.am b/tests/examples/Makefile.am
index 57ed6ddc3..c9b5e0b57 100644
--- a/tests/examples/Makefile.am
+++ b/tests/examples/Makefile.am
@@ -18,6 +18,8 @@ endif
OPENCV_EXAMPLES=opencv
+MATRIXMIX_DIR=audiomixmatrix
+
if USE_OPENGL
GL_DIR=gl
else
@@ -57,8 +59,8 @@ playout_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_CFLAGS)
playout_LDADD = $(GST_PLUGINS_BASE_LIBS) -lgstvideo-$(GST_API_VERSION) $(GST_LIBS)
SUBDIRS= codecparsers mpegts $(DIRECTFB_DIR) $(GTK_EXAMPLES) $(OPENCV_EXAMPLES) \
- $(GL_DIR) $(GTK3_DIR) $(AVSAMPLE_DIR) $(WAYLAND_DIR)
+ $(GL_DIR) $(GTK3_DIR) $(AVSAMPLE_DIR) $(WAYLAND_DIR) $(MATRIXMIX_DIR)
DIST_SUBDIRS= codecparsers mpegts camerabin2 directfb mxf opencv uvch264 gl gtk \
- avsamplesink waylandsink
+ avsamplesink waylandsink audiomixmatrix
include $(top_srcdir)/common/parallel-subdirs.mak