summaryrefslogtreecommitdiff
path: root/sys/vdpau/gstvdp/Makefile.am
diff options
context:
space:
mode:
authorCarl-Anton Ingmarsson <ca.ingmarsson@gmail.com>2010-06-26 21:02:53 +0200
committerCarl-Anton Ingmarsson <ca.ingmarsson@gmail.com>2010-06-26 21:27:32 +0200
commitd13a122a56b0b5eb317ce09529437dd57f0a7fdd (patch)
tree1dd8214d854be5074ee05835294ba6adeb1c2eac /sys/vdpau/gstvdp/Makefile.am
parent71620e7fbb091a62efb1d310870e714fea78df2d (diff)
vdpau: add GstVdpDecoder base class
Diffstat (limited to 'sys/vdpau/gstvdp/Makefile.am')
-rw-r--r--sys/vdpau/gstvdp/Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/sys/vdpau/gstvdp/Makefile.am b/sys/vdpau/gstvdp/Makefile.am
index a4d2a7bfb..4f188472f 100644
--- a/sys/vdpau/gstvdp/Makefile.am
+++ b/sys/vdpau/gstvdp/Makefile.am
@@ -7,6 +7,7 @@ libgstvdp_@GST_MAJORMINOR@_la_SOURCES = \
gstvdpoutputbuffer.c \
gstvdpvideosrcpad.c \
gstvdpoutputsrcpad.c \
+ gstvdpdecoder.c \
gstvdp.c
libgstvdp_@GST_MAJORMINOR@includedir = $(includedir)/gstreamer-@GST_MAJORMINOR@/gst/vdpau
@@ -16,13 +17,15 @@ libgstvdp_@GST_MAJORMINOR@include_HEADERS = \
gstvdpoutputbuffer.h \
gstvdpvideosrcpad.h \
gstvdpoutputsrcpad.h \
+ gstvdpdecoder.h \
gstvdp.h
libgstvdp_@GST_MAJORMINOR@_la_CFLAGS = $(GST_CFLAGS) $(GST_BASE_CFLAGS) \
$(GST_PLUGINS_BASE_CFLAGS) $(X11_CFLAGS) $(VDPAU_CFLAGS)
libgstvdp_@GST_MAJORMINOR@_la_LIBADD = $(GST_LIBS) $(X11_LIBS) $(VDPAU_LIBS) \
- -lgstvideo-$(GST_MAJORMINOR)
+ -lgstvideo-$(GST_MAJORMINOR) \
+ ../basevideodecoder/libgstbasevideodecoder.la
libgstvdp_@GST_MAJORMINOR@_la_LDFLAGS = $(GST_LIB_LDFLAGS) $(GST_LT_LDFLAGS) $(GST_ALL_LDFLAGS)
libgstvdp_@GST_MAJORMINOR@_la_LIBTOOLFLAGS = --tag=disable-static \ No newline at end of file