summaryrefslogtreecommitdiff
path: root/sys/osxvideo/Makefile.am
diff options
context:
space:
mode:
authorMichael Smith <msmith@songbirdnest.com>2009-10-29 16:34:23 -0700
committerMichael Smith <msmith@songbirdnest.com>2009-10-29 16:35:13 -0700
commit942127400623037116fce441916c1678f4291e14 (patch)
treea9a6df02a0006da108f6f6fa71ccf61a1de0c0a6 /sys/osxvideo/Makefile.am
parent91499fd9a78c2175f6be64d655ab8bedfc86fc9e (diff)
osxvideosrc: change a .m file containing only C code to a .c file. Makes
building this easier.
Diffstat (limited to 'sys/osxvideo/Makefile.am')
-rw-r--r--sys/osxvideo/Makefile.am4
1 files changed, 1 insertions, 3 deletions
diff --git a/sys/osxvideo/Makefile.am b/sys/osxvideo/Makefile.am
index dd46e99c1..53391f7ed 100644
--- a/sys/osxvideo/Makefile.am
+++ b/sys/osxvideo/Makefile.am
@@ -1,7 +1,7 @@
plugin_LTLIBRARIES = libgstosxvideosrc.la
-libgstosxvideosrc_la_SOURCES = osxvideoplugin.m osxvideosrc.c
+libgstosxvideosrc_la_SOURCES = osxvideoplugin.c osxvideosrc.c
libgstosxvideosrc_la_CFLAGS = $(GST_CFLAGS) $(GST_BASE_CFLAGS) \
$(GST_PLUGINS_BASE_CFLAGS) -Wno-deprecated-declarations
libgstosxvideosrc_la_LIBADD = \
@@ -13,6 +13,4 @@ libgstosxvideosrc_la_LIBTOOLFLAGS = --tag=disable-static
libgstosxvideosrc_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS) \
-Wl,-framework -Wl,Cocoa -Wl,-framework -Wl,QuickTime
-AM_OBJCFLAGS=$(CFLAGS) $(GST_CFLAGS) $(GST_PLUGINS_BASE_CFLAGS) $(GST_BASE_CFLAGS)
-
noinst_HEADERS = osxvideosrc.h