summaryrefslogtreecommitdiff
path: root/gst/camerabin2/Makefile.am
diff options
context:
space:
mode:
authorThiago Santos <thiago.sousa.santos@collabora.co.uk>2010-11-25 13:00:50 -0300
committerThiago Santos <thiago.sousa.santos@collabora.co.uk>2010-12-08 15:38:26 -0300
commit94da473ba7c216025f3c6c52897a6377ce72ba05 (patch)
treed6c8be232ded6902ee9530649c3040d213040da1 /gst/camerabin2/Makefile.am
parent12245366d811f94724865ef8e3b7ab1d54cceb2d (diff)
camerabin2: Adding v4l2camerasrc from robclark's branch
Adds 3-pad v4l2 camera source from Rob Clark's camerabin branch on http://gitorious.org/robclark-gstreamer/gst-plugins-bad
Diffstat (limited to 'gst/camerabin2/Makefile.am')
-rw-r--r--gst/camerabin2/Makefile.am17
1 files changed, 14 insertions, 3 deletions
diff --git a/gst/camerabin2/Makefile.am b/gst/camerabin2/Makefile.am
index 49d29aa00..25b1e61ed 100644
--- a/gst/camerabin2/Makefile.am
+++ b/gst/camerabin2/Makefile.am
@@ -2,17 +2,28 @@ plugin_LTLIBRARIES = libgstcamerabin2.la
libgstcamerabin2_la_SOURCES = gstviewfinderbin.c \
gstimagecapturebin.c \
+ camerabingeneral.c \
+ gstbasecamerasrc.c \
+ gstcamerabin-enum.c \
+ gstv4l2camerasrc.c \
gstplugin.c
libgstcamerabin2_la_CFLAGS = \
$(GST_PLUGINS_BAD_CFLAGS) \
- $(GST_CFLAGS) $(GST_BASE_CFLAGS) $(GST_PLUGINS_BASE_CFLAGS)
+ $(GST_CFLAGS) $(GST_BASE_CFLAGS) $(GST_PLUGINS_BASE_CFLAGS) \
+ -DGST_USE_UNSTABLE_API
libgstcamerabin2_la_LIBADD = \
- $(GST_LIBS) $(GST_BASE_LIBS) $(GST_PLUGINS_BASE_LIBS)
+ $(top_builddir)/gst-libs/gst/interfaces/libgstphotography-$(GST_MAJORMINOR).la \
+ $(GST_LIBS) $(GST_BASE_LIBS) $(GST_PLUGINS_BASE_LIBS) \
+ -lgstinterfaces-$(GST_MAJORMINOR) -lgsttag-$(GST_MAJORMINOR)
libgstcamerabin2_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
libgstcamerabin2_la_LIBTOOLFLAGS = --tag=disable-static
noinst_HEADERS = gstviewfinderbin.h \
- gstimagecapturebin.h
+ gstimagecapturebin.h \
+ camerabingeneral.h \
+ gstbasecamerasrc.h \
+ gstv4l2camerasrc.h \
+ gstcamerabin-enum.h