summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSebastian Dröge <sebastian.droege@collabora.co.uk>2012-12-21 14:28:57 +0100
committerSebastian Dröge <sebastian.droege@collabora.co.uk>2012-12-21 14:33:56 +0100
commitfaa23b57b824bd9e4f7177691f17b2056967c9e8 (patch)
tree6e4dafc17ef94d205f5d0ebce1aa503a89aac5e2 /configure.ac
parentadfdfebc8c4e38b32cc673cc78991a01d972f6b1 (diff)
configure: Pass CC, LD, AS, AR and NM to the libav configure if set
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac20
1 files changed, 20 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index c8233fa..0695a8a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -338,6 +338,26 @@ else
;;
esac
+ if test x"$AR" != x; then
+ emblibav_configure_args="$emblibav_configure_args --ar=\\\"\\\$AR\\\""
+ fi
+
+ if test x"$AS" != x; then
+ emblibav_configure_args="$emblibav_configure_args --as=\\\"\\\$AS\\\""
+ fi
+
+ if test x"$CC" != x; then
+ emblibav_configure_args="$emblibav_configure_args --cc=\\\"\\\$CC\\\""
+ fi
+
+ if test x"$LD" != x; then
+ emblibav_configure_args="$emblibav_configure_args --ld=\\\"\\\$CC\\\""
+ fi
+
+ if test x"$NM" != x; then
+ emblibav_configure_args="$emblibav_configure_args --nm=\\\"\\\$NM\\\""
+ fi
+
dnl checks for extra enable/disable flags
LIBAV_OPTS="(cd $srcdir/gst-libs/ext/libav && ./configure --help)"
# Let's check if we can disable the building of the libav binary