summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRalf Habacker <ralf.habacker@freenet.de>2022-03-02 11:00:06 +0100
committerRalf Habacker <ralf.habacker@freenet.de>2022-03-02 14:35:54 +0100
commitd74fee2727617778aafe42dc6ea7519876efe9a8 (patch)
tree31c5954da40aac296f7aa3f9905d2b5253f035e0 /CMakeLists.txt
parent9b426c7916a98d24e61e6bbbe6c466e4e9b02fef (diff)
cmake: setup variable WORDS_BIGENDIAN correctly
Since version 3.0 cmake provides the macro test_big_endian for that purpose. fixes #375 Signed-off-by: Ralf Habacker <ralf.habacker@freenet.de>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0e1fc413..a29bddcf 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -28,6 +28,10 @@ include(MacrosAutotools)
autoinit(configure.ac)
autoversion(dbus)
+# replacement for AC_C_BIGENDIAN
+include (TestBigEndian)
+test_big_endian(WORDS_BIGENDIAN)
+
if(EXISTS ${CMAKE_SOURCE_DIR}/config.h.in)
autoheaderchecks(${CMAKE_SOURCE_DIR}/config.h.in ${CMAKE_SOURCE_DIR}/cmake/ConfigureChecks.cmake ${CMAKE_SOURCE_DIR}/cmake/config.h.cmake)
else()