summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRalf Habacker <ralf.habacker@freenet.de>2020-04-28 19:03:59 +0200
committerRalf Habacker <ralf.habacker@freenet.de>2020-04-29 15:23:23 +0000
commit6e8d75834eac4c4b9be78a8104993b3b76fb7dca (patch)
tree2c70a04d5af230aef843b9de5da07070c62d9d62 /CMakeLists.txt
parentdc9a0af697bd3bff6504669ef732b0eaad2478a7 (diff)
Add support to generate the api documentation in Qt help format
Qt help files are used by Qt Creator and KDevelop, for example, to support the development of Qt-based applications and libraries. Generating api documentation in Qt help format is controlled by two user specific options named --enable-qt-help and --with-qchdir (autotools) and -DENABLE_QT_HELP and -DINSTALL_QCH_DIR (cmake).
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0d00d6ed..ec199df0 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -605,6 +605,7 @@ message(" installing system libs: ${DBUS_INSTALL_SYSTEM_LIBS} "
message(" Building inotify support: ${DBUS_BUS_ENABLE_INOTIFY} ")
message(" Building kqueue support: ${DBUS_BUS_ENABLE_KQUEUE} ")
message(" Building Doxygen docs: ${DBUS_ENABLE_DOXYGEN_DOCS} ")
+message(" Building Qt help docs: ${DBUS_ENABLE_QTHELP_DOCS} ")
message(" Building XML docs: ${DBUS_ENABLE_XML_DOCS} ")
message(" Daemon executable name: ${DBUS_DAEMON_NAME}")
if(WIN32)