summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <smcv@collabora.com>2021-09-14 16:48:18 +0100
committerSimon McVittie <smcv@collabora.com>2021-09-15 18:49:14 +0100
commit98cbe2b3ace53ef70738345548402cb4e74a4db7 (patch)
tree8214142a629fc4d45b0fc647860b7ae4bd6b9776 /Makefile.am
parentabd5b946bb2ca9b6c4d2f5e455aaaae5f38946c6 (diff)
Remove support for Python 2
Python 2 reached EOL on 2020-01-01, and the latest version of AX_PYTHON_DEVEL breaks the build with Python 2. This seems as good a time as any to drop compatibility. Signed-off-by: Simon McVittie <smcv@collabora.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 1 insertions, 12 deletions
diff --git a/Makefile.am b/Makefile.am
index fb5390f..77c65ca 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -175,12 +175,6 @@ nobase_python_PYTHON = \
dbus/service.py \
dbus/types.py
-if !HAVE_PYTHON_3
-nobase_python_PYTHON += \
- dbus/gobject_service.py \
- $(NULL)
-endif
-
check_py_sources = $(nobase_python_PYTHON)
include $(top_srcdir)/tools/check-coding-style.mk
@@ -241,6 +235,7 @@ dist_test_sh = \
dist_test_py = \
test/test-client.py \
+ test/test-exception-py3.py \
test/test-p2p.py \
test/test-signals.py \
test/test-standalone.py \
@@ -259,12 +254,6 @@ dist_test_extra_scripts = \
test/wait-for-name.py \
$(NULL)
-if HAVE_PYTHON_3
-dist_test_py += test/test-exception-py3.py
-else
-dist_test_py += test/test-exception-py2.py
-endif
-
test_programs = \
test/test-import-repeatedly \
$(NULL)