summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <smcv@debian.org>2016-03-05 23:49:51 +0000
committerSimon McVittie <smcv@debian.org>2016-03-05 23:49:51 +0000
commit506945f13c098f2b9abcccf681e64d6b924da3eb (patch)
tree3445e048fb36975d30fc5619621529f7a7dcfdb2 /Makefile.am
parentb6e1a0ce33969dc56fade2a5839848f4a926b8bb (diff)
Stop breaking a pre-existing PYTHONPATH in installed-tests' environment
${PYTHONPATH} in Exec= isn't substituted by gnome-desktop-testing. If we rely on the fact that Python prepends the scripts' directory to sys.path, then we don't need to alter PYTHONPATH at all. Signed-off-by: Simon McVittie <smcv@debian.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 6 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index 851b894..e1b328a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -75,9 +75,9 @@ pyexec_LTLIBRARIES = \
$(NULL)
if ENABLE_INSTALLED_TESTS
-installed_test_LTLIBRARIES = dbus_py_test.la
+nobase_installed_test_LTLIBRARIES = test/dbus_py_test.la
else
-noinst_LTLIBRARIES = dbus_py_test.la
+noinst_LTLIBRARIES = test/dbus_py_test.la
endif
_dbus_bindings_la_LDFLAGS = \
@@ -135,13 +135,13 @@ _dbus_glib_bindings_la_SOURCES = \
$(NULL)
# unconditionally add an -rpath to force Libtool to build a shared library
-dbus_py_test_la_LDFLAGS = \
+test_dbus_py_test_la_LDFLAGS = \
$(pymod_ldflags) \
$(AM_LDFLAGS) \
-rpath $(installed_testdir) \
$(NULL)
-dbus_py_test_la_LIBADD = $(DBUS_LIBS)
-dbus_py_test_la_SOURCES = \
+test_dbus_py_test_la_LIBADD = $(DBUS_LIBS)
+test_dbus_py_test_la_SOURCES = \
include/dbus/dbus-python.h \
test/dbus_py_test.c \
$(NULL)
@@ -199,7 +199,7 @@ AM_TESTS_ENVIRONMENT = \
export DBUS_TEST_TMPDIR="$(abs_top_builddir)/test"; \
export DBUS_TEST_UNINSTALLED=1; \
export DBUS_PYTHON_VERSION='$(PACKAGE_VERSION)'; \
- export PYTHONPATH="$(abs_top_srcdir):$(abs_top_srcdir)/test:$(abs_top_builddir)/.libs"; \
+ export PYTHONPATH="$(abs_top_srcdir):$(abs_top_srcdir)/test:$(abs_top_builddir)/.libs:$(abs_top_builddir)/test/.libs"; \
export PYTHON='$(PYTHON)'; \
export DBUS_FATAL_WARNINGS=1; \
$(NULL)
@@ -225,7 +225,6 @@ endif
installed_log_compiler += \
env \
PYTHON=$(PYTHON) \
- PYTHONPATH=$(installed_testdir):$${PYTHONPATH} \
DBUS_TOP_SRCDIR=$(installed_testdir) \
DBUS_TOP_BUILDDIR=$(installed_testdir) \
$(NULL)