summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorChris Wilson <chris@chris-wilson.co.uk>2008-09-14 11:20:25 +0100
committerChris Wilson <chris@chris-wilson.co.uk>2008-09-15 16:28:52 +0100
commitcac2ea0fcda2222f36ebd3414f91302dad691b85 (patch)
tree6305e772ca797c5cb4c30bca655cd6f6a933fac2 /Makefile.am
parent4e731f7c907a3b5bf2da0d73a699bcf79c1f2c85 (diff)
[Makefile] Disable doc/ if we don't have gtk-doc.
make check dies in the documentation even if we have explicitly disabled gtk-doc - so only enter doc/ with gtk-doc enabled.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 48ac8551f..13c1862d0 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,7 +3,11 @@ include $(top_srcdir)/build/Makefile.am.common
ACLOCAL_AMFLAGS = -I build
DIST_SUBDIRS = src boilerplate test perf doc util
-SUBDIRS = src doc
+SUBDIRS = src
+# gtk-doc is required for our documentation
+if ENABLE_GTK_DOC
+SUBDIRS += doc
+endif
# libpng is required for our test programs
if CAIRO_HAS_PNG_FUNCTIONS
SUBDIRS += boilerplate test perf