summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDan Winship <danw@gnome.org>2014-07-04 13:26:57 -0400
committerDan Winship <danw@gnome.org>2014-08-01 14:34:04 -0400
commiteedcf185a7615c68281f2dc33f315efbaeee93c8 (patch)
tree869bf573f7863e374acf89d7c56bd06f094097fd /Makefile.am
parentd595f7843e31e8312c0baf25b476b6489cff59a7 (diff)
libnm: add libnm/libnm-core (part 2)
This fixes up the code from the previous "clean" import, and adds build infrastructure. [There are two slightly orthogonal sets of changes in this patch. First, the files added in the previous commit were modified as followed: # Replace internal references to "libnm-util" and "libnm-glib" with "libnm" perl -pi -e 's/libnm-(util|glib)/libnm/;' libnm-core/*.[ch] libnm-core/tests/*.[ch] libnm/*.[ch] libnm/tests/*.[ch] # Fix includes of the enum-types files perl -pi -e 's/nm-utils-enum-types/nm-core-enum-types/;' libnm-core/*.[ch] libnm-core/tests/*.[ch] libnm/*.[ch] libnm/tests/*.[ch] perl -pi -e 's/nm-glib-enum-types/nm-enum-types/;' libnm/*.[ch] libnm/tests/*.[ch] # Fix some python example code perl -pi -e 's/import NMClient/import NM/;' -e 's/NMClient.Client\(\)/NM.Client()/;' libnm/nm-client.c Then, the build infrastructure was added (without further modifying any existing files in libnm-core or libnm.) Note: to regenerate libnm.ver after rebase: (head -2 libnm-util/libnm-util.ver; (grep -h '\s'nm_ libnm-util/libnm-util.ver libnm-glib/libnm-glib.ver | env LANG=C sort); tail -3 libnm-util/libnm-util.ver) > libnm/libnm.ver ]
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 54992d42bf..b3d41584a6 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -3,6 +3,8 @@ include $(GLIB_MAKEFILE)
SUBDIRS = \
. \
include \
+ libnm-core \
+ libnm \
libnm-util \
libnm-glib \
introspection \