summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorDan Winship <danw@gnome.org>2014-06-13 11:07:02 -0400
committerDan Winship <danw@gnome.org>2014-06-19 17:45:02 -0400
commitdcc109516d4e8706836031ad175ce9176f7c3c72 (patch)
tree56d4cf7f9b3c5d437182e2a5c3bc861fe85f8bbd /Makefile.am
parente8577083cafdf0a164679db11ca9193605e4fffe (diff)
libnm-util: build nm-setting-docs.xml from gtk-doc and GParamSpecs
Add generate-setting-docs.py, based on tools/generate-settings-spec.c, which generates a simple XML file describing all libnm setting properties (still getting the default values via GParamSpec introspection like generate-settings-spec.c does, but getting the documentation out of the gtk-doc strings in the GIR file instead).
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index b41bfa90f1..2da8f194bd 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -44,6 +44,17 @@ DISTCHECK_CONFIGURE_FLAGS = \
--enable-ifupdown \
--enable-ifnet
+if HAVE_INTROSPECTION
+dist-check-introspection:
+else
+dist-check-introspection:
+ @echo "*** gobject-introspection is needed to run 'make dist'. ***"
+ @echo "*** It was not enabled when 'configure' ran. ***"
+ @false
+endif
+
+dist: dist-check-introspection
+
DISTCLEANFILES = intltool-extract intltool-merge intltool-update
pkgconfigdir = $(libdir)/pkgconfig