summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAleksander Morgado <aleksander@aleksander.es>2017-09-13 18:41:06 +0200
committerAleksander Morgado <aleksander@aleksander.es>2017-09-13 19:38:11 +0200
commitbfff4f53e61ac4251eac062ba7e53d52b51a1bec (patch)
tree265e438c2aafd15daba5cbd6ede360ee94d9d712 /Makefile.am
parent5ee58513c749302507e1338feb79a53135c72759 (diff)
build: generate ChangeLog from git during dist
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index a85e4154..1002182d 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -19,6 +19,19 @@ SUBDIRS = \
docs \
$(NULL)
+ChangeLog:
+ $(AM_V_GEN) if test -d "$(srcdir)/.git"; then \
+ (GIT_DIR=$(top_srcdir)/.git $(top_srcdir)/missing --run git log --stat) | fmt --split-only > $@.tmp \
+ && mv -f $@.tmp $@ \
+ || ($(RM) $@.tmp; \
+ echo Failed to generate ChangeLog, your ChangeLog may be outdated >&2; \
+ (test -f $@ || echo git-log is required to generate this file >> $@)); \
+ else \
+ test -f $@ || \
+ (echo A git checkout and git-log is required to generate ChangeLog >&2 && \
+ echo A git checkout and git-log is required to generate this file >> $@); \
+ fi
+
AM_DISTCHECK_CONFIGURE_FLAGS = \
--with-udev-base-dir="$$dc_install_base" \
--with-systemdsystemunitdir="$$dc_install_base/$(SYSTEMD_UNIT_DIR)" \