summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAleksander Morgado <aleksander@lanedo.com>2011-10-18 19:57:17 +0200
committerAleksander Morgado <aleksander@lanedo.com>2012-03-15 14:14:18 +0100
commit365b906a3e1bda05af10f92451a6b6ae60f8b879 (patch)
tree8363d61c92f8419d041f73c3e42de8fbf595ffd4 /Makefile.am
parent4643dca4a2bd70c71fb825f6d98334a5bf608b94 (diff)
build: setup header generator in its own include/Makefile
Also move helper files to the new `build-aux' directory.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am11
1 files changed, 1 insertions, 10 deletions
diff --git a/Makefile.am b/Makefile.am
index dd35a28e..095bd162 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -20,7 +20,7 @@ all: $(GENERATED_FILES)
CLEANFILES = $(GENERATED_FILES)
endif
-SUBDIRS = . marshallers libqcdm libwmc src plugins introspection po test
+SUBDIRS = . marshallers build-aux include libqcdm libwmc src plugins introspection po test
if WITH_POLKIT
SUBDIRS += policy
@@ -44,14 +44,6 @@ dbusactivationdir = $(datadir)/dbus-1/system-services
dbusactivation_in_files = org.freedesktop.ModemManager.service.in
dbusactivation_DATA = $(dbusactivation_in_files:.service.in=.service)
-includedir = @includedir@/mm
-
-include_HEADERS = include/ModemManager.h
-
-include/ModemManager.h: $(XMLS) introspection/all.xml header-generator.xsl
- @install -d include
- $(XSLTPROC) $(top_srcdir)/header-generator.xsl $(top_srcdir)/introspection/all.xml > $@
-
%service: %service.in
$(edit) $< >$@
@@ -84,7 +76,6 @@ DISTCLEANFILES = \
EXTRA_DIST = \
doc-generator.xsl \
- header-generator.xsl \
$(dbusactivation_in_files) \
$(INTLTOOL_FILES) \
$(dbusservice_file_polkit) \